Team Ai
Datasetpublic

codekingpro/portable-devtools

sourceHugging Faceupdated 5mo agoView on Hugging Face
1likes14kdownloads
1Metadata-Version: 2.12Name: Authlib3Version: 1.3.04Summary: The ultimate Python library in building OAuth and OpenID Connect servers and clients.5Author-email: Hsiaoming Yang <me@lepture.com>6License: BSD-3-Clause7Project-URL: Documentation, https://docs.authlib.org/8Project-URL: Purchase, https://authlib.org/plans9Project-URL: Issues, https://github.com/lepture/authlib/issues10Project-URL: Source, https://github.com/lepture/authlib11Project-URL: Donate, https://github.com/sponsors/lepture12Project-URL: Blog, https://blog.authlib.org/13Classifier: Development Status :: 5 - Production/Stable14Classifier: Environment :: Console15Classifier: Environment :: Web Environment16Classifier: Intended Audience :: Developers17Classifier: License :: OSI Approved :: BSD License18Classifier: Operating System :: OS Independent19Classifier: Programming Language :: Python20Classifier: Programming Language :: Python :: 321Classifier: Programming Language :: Python :: 3.822Classifier: Programming Language :: Python :: 3.923Classifier: Programming Language :: Python :: 3.1024Classifier: Programming Language :: Python :: 3.1125Classifier: Programming Language :: Python :: Implementation :: CPython26Classifier: Topic :: Security27Classifier: Topic :: Security :: Cryptography28Classifier: Topic :: Internet :: WWW/HTTP :: Dynamic Content29Classifier: Topic :: Internet :: WWW/HTTP :: WSGI :: Application30Requires-Python: >=3.831Description-Content-Type: text/x-rst32License-File: LICENSE33Requires-Dist: cryptography34 35Authlib36=======37 38The ultimate Python library in building OAuth and OpenID Connect servers.39JWS, JWK, JWA, JWT are included.40 41Useful Links42------------43 441. Homepage: https://authlib.org/452. Documentation: https://docs.authlib.org/463. Purchase Commercial License: https://authlib.org/plans474. Blog: https://blog.authlib.org/485. More Repositories: https://github.com/authlib496. Twitter: https://twitter.com/authlib507. Donate: https://www.patreon.com/lepture51 52Specifications53--------------54 55- RFC5849: The OAuth 1.0 Protocol56- RFC6749: The OAuth 2.0 Authorization Framework57- RFC6750: The OAuth 2.0 Authorization Framework: Bearer Token Usage58- RFC7009: OAuth 2.0 Token Revocation59- RFC7515: JSON Web Signature60- RFC7516: JSON Web Encryption61- RFC7517: JSON Web Key62- RFC7518: JSON Web Algorithms63- RFC7519: JSON Web Token64- RFC7521: Assertion Framework for OAuth 2.0 Client Authentication and Authorization Grants65- RFC7523: JSON Web Token (JWT) Profile for OAuth 2.0 Client Authentication and Authorization Grants66- RFC7591: OAuth 2.0 Dynamic Client Registration Protocol67- RFC7636: Proof Key for Code Exchange by OAuth Public Clients68- RFC7638: JSON Web Key (JWK) Thumbprint69- RFC7662: OAuth 2.0 Token Introspection70- RFC8037: CFRG Elliptic Curve Diffie-Hellman (ECDH) and Signatures in JSON Object Signing and Encryption (JOSE)71- RFC8414: OAuth 2.0 Authorization Server Metadata72- RFC8628: OAuth 2.0 Device Authorization Grant73- OpenID Connect 1.074- OpenID Connect Discovery 1.075- draft-madden-jose-ecdh-1pu-04: Public Key Authenticated Encryption for JOSE: ECDH-1PU76 77Implementations78---------------79 80- Requests OAuth 1 Session81- Requests OAuth 2 Session82- Requests Assertion Session83- HTTPX OAuth 1 Session84- HTTPX OAuth 2 Session85- HTTPX Assertion Session86- Flask OAuth 1/2 Client87- Django OAuth 1/2 Client88- Starlette OAuth 1/2 Client89- Flask OAuth 1.0 Server90- Flask OAuth 2.0 Server91- Flask OpenID Connect 1.092- Django OAuth 1.0 Server93- Django OAuth 2.0 Server94- Django OpenID Connect 1.095 96License97-------98 99Authlib is licensed under BSD. Please see LICENSE for licensing details.100 101If this license does not fit your company, consider to purchase a commercial102license. Find more information on `Authlib Plans`_.103 104.. _`Authlib Plans`: https://authlib.org/plans105 
codekingpro/portable-devtools · Team Ai